Exos Gns3

 
  1. Exos Gns3 Switch
  2. Exos Vm Gns3 Github
  3. Exos Gns3 2

BFD Overview

Build, Design and Test your network in a risk-free virtual environment and access the largest networking community to help. Whether you are studying for your first networking exam or building out a state-wide telecommunications network, GNS3 offers an easy way to design and build networks of any size without the need for hardware. In the below example, EXOS image 22.6.1.4 is installed in the Secondary Partition and selected for the next reboot. Exosswitch.2 # show switch SysName: exosswitch. MikroTik RouterOS is the stand-alone operating system of MikroTik RouterBOARD hardware. It can also be installed on a PC and will turn it into a router with all the necessary features - routing, firewall, bandwidth, management, wireless access point, backhaul link, hotspot, gateway, VPN server and more.

Bidirectional Forwarding Detection (BFD) is a hello protocol that provides the rapid detection of failures in the path and informs the clients (routing protocols) to initiate the route convergence.
It is independent of media, routing protocols, and data protocols. BFD helps in the separation of forwarding plane connectivity and control plane connectivity.
Different routing protocol hello mechanisms operate in variable rates of detection, but BFD detects the forwarding path failures at a uniform rate, thus allowing for easier network profiling and planning, and consistent and predictable re-convergence time.

OSPFv3 BFD

BFD can be used by other routing protocol including OSPFv3 the procedure for session setup and tearing down as below

BFD/OSPF session setup

  • Router sends a request to the local BFD process to initiate a BFD neighbor session with the OSPF neighbor router
  • The BFD neighbor session with the OSPF neighbor router is established

Tearing Down BFD/OSPF session

Exos Gns3

  • A failure occurs in the network.
  • The BFD neighbor session with the OSPF neighbor router is torn down.
  • BFD notifies the local OSPF process that the BFD neighbor is no longer reachable.
  • The local OSPF process tears down the OSPF neighbor relationship. If an alternative path is available the routers will immediately start converging on it
Configuration Example

One of EXTREME Customer is using 100 msec bfd interval, and routing protocol like OSPF, LDP, BGP take advantage of BFD.

enable bfd vlan 't1'

configure bfd vlan 't1' receive-interval 100 transmit-interval 100

enable bfd vlan 't2'

configure bfd vlan 't2' receive-interval 100 transmit-interval 100

enable bfd vlan 't3'

configure bfd vlan 't3' receive-interval 100 transmit-interval 100

enable bfd vlan 't4'

configure bfd vlan 't4' receive-interval 100 transmit-interval 100

enable bfd vlan 't11'

configure bfd vlan 't11' receive-interval 100 transmit-interval 100

Exos

enable mpls bfd vlan 't2'

enable mpls bfd vlan 't3'

enable mpls bfd vlan 't4'

configure ospfv3 vlan t1 bfd on

configure ospfv3 vlan t2 bfd on

configure ospfv3 vlan t3 bfd on

configure ospfv3 vlan t4 bfd on

Above configuration is the lab device configuration to test network convergence time with customer’s configuration.
The following limitations apply to BFD in this release:
  • Direct connection (single hop) networks only are supported.
  • Hitless failover is supported.
  • BFD protocol has been implemented in software. The number of sessions handled by BFD at minimal timers (less than 100ms) varies depending on platform type and processing load (which is effected by other protocols being enabled, or other system conditions such as software forwarding).

MikroTikRouterOS is the stand-alone operating system of MikroTik RouterBOARD hardware. It can also be installed on a PC and will turn it into a router with all the necessary features - routing, firewall, bandwidth, management, wireless access point, backhaul link, hotspot, gateway, VPN server and more.

The tutorial explains how to install RouterOS on Qemu virtual disk and configure GNS3 software to run such a router. Later, We will use GNS3 to a create simple testing topology with one RoutersOS router connected to emulated Cisco 3725 router.

You can download Mikrotik RouterOS x86 installed on Qemu and VirtualBox images in the Download section here.

Software Prerequisites

  • GNS3 with Qemu or VirtualBox support
  • Qemu or VirtualBox
  • RouterOS ISO image - mikrotik-6.37.5.iso

Virtual Machine Prerequisites

  • i386 compatible architecture
  • minimum 32MB of RAM (maximum supported 2GB)
  • minimum Hard Disk space 64MB
  • Network cards supported by linux v3.3.5 kernel (PCI, PCI-X)

RouterOS x86 Installation

1. Download RouterOS for x86 Architecture

$ wget https://download2.mikrotik.com/routeros/6.37.5/mikrotik-6.37.5.iso

2. Create Qemu Virtual Disk and Start Virtual Machine

$ /usr/local/bin/qemu-img create -f qcow2 routeros-6.37.5.img 200M
$ /usr/local/bin/qemu-system-i386 -m 512 -enable-kvm -boot d -cdrom mikrotik-6.37.5.iso routeros-6.37.5.img

3. Install RouterOS

Use spacebar to select packages that are needed. Then press 'i' to install RouterOS.

Picture 1 - RouterOS Installation

Once RouterOS is installed, you have 24 hours to enter a license key to activate RouterOS Qemu image. The timer stops if router is shutdowned. For this reason, we let GNS3 automatically create the copy of base Qemu image every time is a new RouterOS instance placed on the GNS3 desktop. These independent copy of the base image can be run for total 24 hours time period.

4. Start RouterOS Qemu Disk

After the disk is formatted and packages copied, start RouterOS instance with the command:

$ /usr/local/bin/qemu-system-i386 -m 512 -enable-kvm -boot c routeros-6.37.5.img -nographic -serial telnet::4444,server,nowait

You should be able to login to RouterOS with the telnet command:

$ telnet 127.0.0.1 4444

Username is admin without password set.

5. Connect Qemu image to GNS3

I assume that GNS3 is correctly installed and configured.

a) Start GNS3 and create a new GNS3 project

Picture 2 - Creating GNS3 New Project

b) Configure Qemu guest settings

Navigate to Edit -> Preferences -> Qemu -> Qemu Guest and configure parameters as it is shown on the picture below.

Picture 3 - Qemu Guest Settings

RouterOS Configuration

1. Testing Topology

The topology consists of one RouterOS that connects two Microcore Qemu instances. As we want to test switching and VLANs, both Microcore instances are connected to RouterOS switvchport that are separated by VLANs - VLAN10 and VLAN20.

RouterOS's interface Ethernet1 si connected to Cisco 3725 router emulated by Dynamips. The port will be configured as a trunk port on RouterOS side and as a routed port with two sub-interfaces on Cisco's side.

Exos gns3 lite

Picture 4 - Testing Topology

2. Create Bridges for VLAN10 and VLAN20 and Assign Access Ports to Bridges

First, check available Ethernet interfaces.They are six Ethernet interfaces presented in RouterOS console in total.

Picture 5 - Router Ethernet Interfaces

We are going to create bridges br10 and br20 and assign interface Ethernet2 to the bridge br10 and Ethernet3 to br20.

[[email protected]] > /interface bridge add name=br10
[[email protected]] > /interface bridge add name=br20
[[email protected]] > /interface bridge port add interface=ether2 bridge=br10
[[email protected]] > /interface bridge port add interface=ether3 bridge=br20

3. Configure Trunk Port to allow VLAN 10 and VLAN 20 and create Switched Virtual Interfaces - SVI10 and SVI20

[[email protected]] > /interface vlan add vlan-id=10 name=SVI10 interface=ether1 disabled=no
[[email protected]] > /interface vlan add vlan-id=20 name=SVI20 interface=ether1 disabled=no

Note: the term SVI is used in a Cisco world, feel free to change it if you want.

4. Add SVI Ports to Bridges

[[email protected]] > /interface bridge port add interface=SVI10 bridge=br10 disabled=no
[[email protected]] > /interface bridge port add interface=SVI20 bridge=br20 disabled=no

Picture 6 - Bridge Ports Configuration

5. Assign IP address to SVI Ports

This configuration ensures that intervlan routing betwwen VLAN 10 and VLAN20 can be done by RouterOS.

[[email protected]] > /ip address add interface=SVI10 address=192.168.10.254/24 disabled=no
[[email protected]] > /ip address add interface=SVI20 address=192.168.20.254/24 disabled=no

At this point you should be able to make successful ping between PC1 and PC2.

6. Set password and hostname

[[email protected]] > /password new-password=admin
[[email protected]] > /system identity set name=RouterOS-I

7. Static routing configuration

[[email protected]] > /ip route add dst-address=10.10.10.10/32 gateway=192.168.10.253

Picture 7 - Routing Table

End hosts PC1 and PC2 Configuration

Exos Gns3 Switch

End hosts are represent by Microcore Linux 3.8.2 installed on Qemu virtual disks. Ethernet interfaces configuration is stored in the file /opt/bootlocal.sh that is started during the boot of Microcore. To save configuration changes, the script /usr/bin/filetool.sh must be called with parameter -b.

PC1
[email protected]:~$ sudo su
[email protected]:# echo 'ifconfig eth0 192.168.10.1 netmask 255.255.255.0 up' >> /opt/bootlocal.sh
[email protected]:# echo 'hostname PC2' >> /opt/bootlocal.sh
[email protected]:# echo 'route add default gw 192.168.10.254' >> /opt/bootlocal.sh

[email protected]:~# /opt/bootlocal.sh
[email protected]:~# /usr/bin/filetool.sh -b

Exos Vm Gns3 Github

PC2
[email protected]:~$ sudo su
[email protected]:# echo 'ifconfig eth0 192.168.20.1 netmask 255.255.255.0 up' >> /opt/bootlocal.sh
[email protected]:# echo 'hostname PC2' >> /opt/bootlocal.sh
[email protected]:# echo 'route add default gw 192.168.20.254' >> /opt/bootlocal.sh

[email protected]:~# /opt/bootlocal.sh
[email protected]:~# /usr/bin/filetool.sh -b

Cisco 3725 Configuration

1. Router-on-the-stick Configuration

Exos Gns3 2

3725#conf t
3725(config)#interface fastEthernet 0/0
3725(config-if)#no shut
3725(config-if)#exit

3725(config)#interface FastEthernet 0/0.10
3725(config-subif)#encapsulation dot1Q 10
3725(config-subif)#ip address 192.168.10.253 255.255.255.0
3725(config-subif)#no shutdown

3725(config-subif)#int fa0/0.20
3725(config-subif)#encapsulation dot1Q 20
3725(config-subif)#ip address 192.168.20.253 255.255.255.0
3725(config-subif)#no shutdown

2. Loopback configuration

725(config)#interface loopback 0
3725(config-if)#ip address 10.10.10.10 255.255.255.255
3725(config-if)#no shutdown

Testing Connectivity

1. Check if RouterOS does Packet Switching Between VLAN10 and VLAN20 Subnets

Issue the command ping on PC1 to test connectivity between PC1 and PC2.

Picture 8 - RouterOS InterVlan Routing

2. Check if VLAN Tagged Traffic is Transferred via Trunk Port

Ping from PC1 to Cisco 3725 router's IP address 192.168.10.253

Picture 9 - Ping from PC1 to Cisco 3725

Picture 10 - Captured Traffic on Cisco 3725 Interface FastEthernet0/0

End.

RouterOS Basic Commands
http://rbmikrotik.blogspot.sk/2011/07/mikrotik-router-os-basic-commands.html

RouterOS x86 Features
http://wiki.mikrotik.com/wiki/Manual:RouterOS_features
http://download2.mikrotik.com/what_is_routeros.pdf

RouterOs Switching
http://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features
http://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_Setup

RouterOS VLANs
http://wiki.mikrotik.com/wiki/Vlans_on_Mikrotik_environment